aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-28 10:22:44 +0100
committerJoão Valverde <j@v6e.pt>2016-03-29 13:41:25 +0000
commitc436452769d7751d2afd347a4953b4628be17836 (patch)
tree2c0c2b09c8fb8232fe44364b0d48be8c14e2b333 /configure.ac
parent66d92e6765de0e6c4b5781278f47063a095af89d (diff)
Add GLib version info to configure status message
Change-Id: I279996e6713cad809a9487a83dc9692e7673f604 Reviewed-on: https://code.wireshark.org/review/14663 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c98adb9abf..08424d9766 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1566,7 +1566,7 @@ AC_SUBST(GLIB_MIN_VERSION)
PKG_WIRESHARK_CHECK_SYSTEM_MODULES([GLIB],
[glib-2.0 >= $GLIB_MIN_VERSION gthread-2.0 >= $GLIB_MIN_VERSION gmodule-2.0 >= $GLIB_MIN_VERSION],
- [],
+ [GLIB_VERSION=`$PKG_CONFIG --modversion glib-2.0`],
[AC_MSG_ERROR([GLib $GLIB_MIN_VERSION or later not found.])])
# Error out if a glib header other than a "top level" header
@@ -3426,6 +3426,7 @@ echo " LIBS: $LIBS"
echo ""
echo "The Wireshark package has been configured with the following options:"
+echo " GLib version : v$GLIB_VERSION"
echo " Build wireshark : $enable_wireshark_qt$qt_lib_message"
echo " Build wireshark-gtk : $have_gtk""$gtk_lib_message"
echo " Build tshark : $enable_tshark"