aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-07-09 08:48:07 +0000
committerGuy Harris <guy@alum.mit.edu>2013-07-09 08:48:07 +0000
commit5967dc68203852e0c4660e4a8cbecd63bb6390d9 (patch)
treef72c7f51fffa0e6b4a8295d008c5db0d53c3e5d3 /configure.ac
parentc72d5f08fb1cd1de05d7496623a519b0130e8249 (diff)
CPPFLAGS contains the flags for the C preprocessor; CXXFLAGS contains
the flags for the C++ compiler. If we're building for 10.5, force a 32-bit build. svn path=/trunk/; revision=50459
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2cd5cdd977..917ab7e91f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -352,7 +352,7 @@ darwin*)
# Add an -isysroot flag to use the SDK.
#
CFLAGS="-mmacosx-version-min=$deploy_target -isysroot $SDKPATH $CFLAGS"
- CPPFLAGS="-mmacosx-version-min=$deploy_target -isysroot $SDKPATH $CPPFLAGS"
+ CXXFLAGS="-mmacosx-version-min=$deploy_target -isysroot $SDKPATH $CXXFLAGS"
LDFLAGS="-mmacosx-version-min=$deploy_target -isysroot $SDKPATH $LDFLAGS"
#
@@ -366,6 +366,21 @@ darwin*)
# flag being set?
#
OSX_DEPLOY_TARGET="MACOSX_DEPLOYMENT_TARGET=$deploy_target"
+
+ case $deploy_target in
+
+ 10.4|10.5)
+ #
+ # Only 32-bit builds are supported. 10.5
+ # (and 10.4?) had a bug that causes some BPF
+ # functions not to work with 64-bit userland
+ # code, so capturing won't work.
+ #
+ CFLAGS="-arch i386 $CFLAGS"
+ CXXFLAGS="-arch i386 $CXXFLAGS"
+ LDFLAGS="-arch i386 $LDFLAGS"
+ ;;
+ esac
fi
esac