aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-21 20:31:00 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2016-02-23 13:10:28 +0000
commitd49e06a5176ed270c22e31078751194a4eec6ca9 (patch)
tree355e76c4d58ff7dfc90f510153edecd32c115916 /configure.ac
parent5d00f39d10ebba19ab2aea719606fa6b218a3658 (diff)
autotools: Display build flags in configure summary
Add more AX_APPEND_FLAGS to handle whitespace better too. Change-Id: I679fc76076c2d800e3524fe7bf22d0af8e58b284 Reviewed-on: https://code.wireshark.org/review/14062 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ec1b65ef56..62027cb36e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1432,7 +1432,7 @@ if test "x$ac_cv_enable_usr_local" = "xyes" ; then
# as various packages we use ("libpcap", "zlib", "adns")
# may have been installed under "/usr/local/include".
#
- WS_CPPFLAGS="$WS_CPPFLAGS -I/usr/local/include"
+ AX_APPEND_FLAG([-I/usr/local/include], [WS_CPPFLAGS])
#
# Arrange that we search for libraries in "/usr/local/lib".
@@ -3425,6 +3425,17 @@ else
fi
echo ""
+echo " CPPFLAGS: $WS_CPPFLAGS $CPPFLAGS"
+echo ""
+echo " CFLAGS: $WS_CFLAGS $CFLAGS"
+echo ""
+echo " CXXFLAGS: $WS_CXXFLAGS $CXXFLAGS"
+echo ""
+echo " LDFLAGS: $WS_LDFLAGS $LDFLAGS"
+echo ""
+echo " LIBS: $LIBS"
+
+echo ""
echo "The Wireshark package has been configured with the following options."
echo " Build wireshark : $enable_wireshark_qt$qt_lib_message"
echo " Build wireshark-gtk : $have_gtk""$gtk_lib_message"