aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2014-03-15 11:35:21 +0100
committerEvan Huus <eapache@gmail.com>2014-03-17 14:32:44 +0000
commitd43f7d134b11cc937fa47110e0512e13f770f777 (patch)
tree4ee1760c5494ae798efb7cb7d62e4b8fe22b166d /configure.ac
parent66d0b1893a8b0786abef967b7f743cedb7143d87 (diff)
Remove -Wunreachable-code it is removed from GCC
http://gcc.gnu.org/ml/gcc-help/2011-05/msg00360.html Change-Id: I3f016611d0dc5e7cc6d53965f9b5d2b1ee88fe1c Reviewed-on: https://code.wireshark.org/review/677 Reviewed-by: Hadriel Kaplan <hadrielk@yahoo.com> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index f4aaf6773f..7d06f77919 100644
--- a/configure.ac
+++ b/configure.ac
@@ -782,15 +782,6 @@ AC_ARG_ENABLE(extra-gcc-checks,
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Woverflow)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fstrict-overflow -Wstrict-overflow=4)
#
- # Some memset() calls to clear out structures
- # on the stack are getting flagged as "will never
- # be executed" by this, at least by Apple's
- # i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on
- # Apple Inc. build 5658) (LLVM build 2336.11.00), for
- # some unknown reason.
- #
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wunreachable-code)
- #
# Due to various places where APIs we don't control
# require us to cast away constness, we can probably
# never enable these ones with -Werror.