aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-01-02 19:19:10 +0000
committerGerald Combs <gerald@wireshark.org>2013-01-02 19:19:10 +0000
commita50850c0cd9852ad0e3e675d473b2ce98e916d95 (patch)
treef3db98c23267f7f374111635d3d9f1d47f6ed852 /configure.ac
parent6e77aef9466cfd320f2ab0ee3761c29db9c8ba98 (diff)
Fix UI library dependency checking.
svn path=/trunk/; revision=46902
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a0f7f4f295..33c8eca434 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1007,9 +1007,8 @@ if test "$have_gtk" = "no" ; then
# wouldn't think we had it, and thus wouldn't be here).
#
wireshark_bin="wireshark\$(EXEEXT)"
- wireshark_ui_lib="ui/qt/libqtui.a"
# Give automake a hint that it needs to use c++ linking.
- have_wireshark_cxx="true"
+ have_wireshark_cxx="yes"
wireshark_man="wireshark.1"
wireshark_SUBDIRS="codecs ui/qt"
else
@@ -1031,7 +1030,6 @@ if test "$have_gtk" = "no" ; then
fi
fi
wireshark_bin=""
- wireshark_ui_lib=""
wireshark_man=""
fi
# Use GLIB_CFLAGS
@@ -1047,7 +1045,6 @@ else
# GTK+, so we wouldn't think we had it, and thus wouldn't be here).
#
wireshark_bin="wireshark\$(EXEEXT)"
- wireshark_ui_lib="ui/gtk/libgtkui.a"
wireshark_man="wireshark.1"
wireshark_SUBDIRS="codecs ui/gtk"
# Don't use GLIB_CFLAGS
@@ -1179,9 +1176,9 @@ then
fi
AC_SUBST(wireshark_bin)
-AC_SUBST(wireshark_ui_lib)
AC_SUBST(wireshark_man)
-AM_CONDITIONAL(HAVE_WIRESHARK_CXX, test "$have_wireshark_cxx" = "true")
+AM_CONDITIONAL(HAVE_Qt, test "$have_qt" = "yes")
+AM_CONDITIONAL(HAVE_WIRESHARK_CXX, test "$have_wireshark_cxx" = "yes")
# Enable/disable tshark