aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-20 13:13:35 +0000
committerJoão Valverde <j@v6e.pt>2016-02-21 07:45:55 +0000
commit8b46cbbceb51f86ccc2efb487cf66024b9174ab4 (patch)
treecfb471ac5a22cf85804251b7b3139dd281253162 /configure.ac
parente282c19520802b6c1d61e29fa6dd72a8a991608c (diff)
autotools: Cleanup some installation directory stuff
Replace hacky code to set install dirs in config.h and use path definitions only where required. Change-Id: I78735f730725382c1b3aca876705e5e6e1872d78 Reviewed-on: https://code.wireshark.org/review/14033 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index e170fb03b7..454f625e41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1538,29 +1538,6 @@ else
AC_MSG_RESULT(no)
fi
-# Create DATAFILE_DIR #define for config.h
-datafiledir=$datadir/wireshark
-datafiledir=`(
- test "x$prefix" = xNONE && prefix=$ac_default_prefix
- test "x$exec_prefix" = xNONE && exec_prefix=${prefix}
- # Ugly hack, but I don't see how this problem can be solved
- # properly that DATAFILE_DIR had a value starting with
- # "${prefix}/" instead of e.g. "/usr/local/"
- eval eval echo "$datafiledir"
-)`
-AC_DEFINE_UNQUOTED(DATAFILE_DIR,"$datafiledir", [Directory for data])
-
-# Create DOC_DIR #define for config.h
-docdir=`(
- test "x$prefix" = xNONE && prefix=$ac_default_prefix
- test "x$exec_prefix" = xNONE && exec_prefix=${prefix}
- # Ugly hack, but I don't see how this problem can be solved
- # properly that DOC_DIR had a value starting with
- # "${prefix}/" instead of e.g. "/usr/local/"
- eval eval echo "$docdir"
-)`
-AC_DEFINE_UNQUOTED(DOC_DIR, "$docdir", [Directory for docs])
-
GTK2_MIN_VERSION=2.12.0
AC_SUBST(GTK2_MIN_VERSION)
GTK3_MIN_VERSION=3.0.0
@@ -3047,7 +3024,6 @@ then
AC_DEFINE(HAVE_PLUGINS, 1, [Define if plugins are enabled])
fi
AC_SUBST(plugindir)
-WS_CPPFLAGS="$WS_CPPFLAGS '-DPLUGIN_INSTALL_DIR=\"\$(plugindir)\"'"
#
# The plugin dissectors reside in ./plugins/PROTO/
@@ -3082,7 +3058,6 @@ then
AC_DEFINE(HAVE_EXTCAP, 1, [Define if external capture sources should be enabled])
fi
AC_SUBST(extcapdir)
-WS_CPPFLAGS="$WS_CPPFLAGS '-DEXTCAP_DIR=\"\$(extcapdir)\"'"
if test "x$enable_sshdump" = "xyes" ; then
if test "x$have_good_libssh" = "xyes" ; then