aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-11-26 23:43:18 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-11-26 23:43:18 +0000
commit69017ac3bdc0877765817e5cd50279a78da2fc11 (patch)
treef67d8f45bfc7c810e203c694b51f63bb721a8ddb /configure.ac
parentcc538dbb6c7f1f31552f39809a241b43442acea5 (diff)
Overhaul rpm-building options a bit: as suggested by Anders, have the RPM follow
./configure's options for gtk2 vs gtk3 vs qt. Make it possible to not build the GNOME package (now both UIs' packages are optional). I think Chris requested this a while ago. If this works out it may make sense to control the rest of the options via ./configure . svn path=/trunk/; revision=53607
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 39 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5eb9c1c9b6..6ad85ae50b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,8 @@ m4_define([version_micro_extra], version_micro)
m4_append([version_micro_extra], [])
AC_INIT(wireshark, [version_major.version_minor.version_micro_extra], http://bugs.wireshark.org/, , http://www.wireshark.org/)
+CONFIG_ARGS="$*"
+AC_SUBST(CONFIG_ARGS)
# Minimum autoconf version we require.
AC_PREREQ(2.60)
@@ -1719,9 +1721,7 @@ AM_CONDITIONAL(HAVE_GTK, test "$have_gtk" = "yes")
AC_SUBST(OSX_APP_FLAGS)
AC_SUBST(OSX_DMG_FLAGS)
-
# Enable/disable tshark
-
AC_ARG_ENABLE(tshark,
AC_HELP_STRING( [--enable-tshark],
[build TShark @<:@default=yes@:>@]),
@@ -2643,6 +2643,43 @@ case $host_cpu in
;;
esac
+# Gather only the "--with*" arguments and also a list of --with arguments for rpmbuild
+for f in $CONFIG_ARGS
+do
+ case $f in
+ --with-gtk2*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with gtk2"
+ ;;
+ --without-gtk2*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --without gtk2"
+ ;;
+ --with-gtk3*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with gtk3"
+ ;;
+ --without-gtk3*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --without gtk3"
+ ;;
+ --with-qt*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with qt"
+ ;;
+ --without-qt*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --without qt"
+ ;;
+ --with*)
+ CONFIG_WITH_ARGS="$CONFIG_WITH_ARGS $f"
+ ;;
+ esac
+
+done
+AC_SUBST(CONFIG_WITH_ARGS)
+AC_SUBST(RPMBUILD_WITH_ARGS)
+
dnl libtool defs
#
# Yes, AM_PROG_LIBTOOL is redundant with newer version(s) of some tool(s)