aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Broman <anders.broman@ericsson.com>2012-09-04 08:57:03 +0000
committerAnders Broman <anders.broman@ericsson.com>2012-09-04 08:57:03 +0000
commit342c344c1fc890ba2b0c68e4d60caf7fc9dfdead (patch)
tree0c7ef235ac04f33f2b77176fe50e52832ad3e4d4 /configure.ac
parent3ccb64d4900d9bb0fa78dc41735a62ba1820c37a (diff)
From Pontus Fuchs:
Fall back to CMD_SET_WIPHY for older kernels. https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6973 svn path=/trunk/; revision=44768
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8a8c07dd64..8697d4dfc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,6 +254,13 @@ elif (test "${have_libnl1}" = "yes"); then
enable_airpcap=no
fi
+AC_MSG_CHECKING([for NL80211_SET_CHANNEL])
+ AC_TRY_COMPILE([#include <linux/nl80211.h>],
+ [enum nl80211_commands x = NL80211_CMD_SET_CHANNEL;],
+ [AC_MSG_RESULT(yes) AC_DEFINE(HAVE_NL80211_CMD_SET_CHANNEL, 1, [SET_CHANNEL is supported])],
+ [AC_MSG_RESULT(no)])
+
+
AC_ARG_WITH([gtk3],
AC_HELP_STRING( [--with-gtk3=@<:@yes/no@:>@],
[use GTK+ 3.0 instead of 2.0 @<:@default=no@:>@]),