aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-23 16:48:41 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-23 23:58:29 +0000
commit213189ef9e7bbd851e145e1cfb1067c7b2b72de8 (patch)
tree67bc7b5ce4a1e36fd16203d12fd184a0aee38965 /configure.ac
parente22d3c9b744af8fa49806f1cde2100be85cc58cc (diff)
Move the routines to talk to dumpcap into a static libcapchild.
This pulls some stuff out of the top-level directory, and means we don't have to build them once for every program using them. Change-Id: I37b31fed20f2d5c3563ecd2bae9fd86af70afff5 Reviewed-on: https://code.wireshark.org/review/2591 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 350cb76924..dfa296dae5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1676,10 +1676,13 @@ LIBS="$ac_save_LIBS"
if test "$ac_cv_glib_supports_modules" = yes ; then
AC_MSG_RESULT(yes)
have_plugins=yes
+ plugins_dir="plugins"
else
AC_MSG_RESULT(no)
have_plugins=no
+ plugins_dir=""
fi
+AC_SUBST(plugins_dir)
#
# If we have <dlfcn.h>, check whether we have dladdr.
@@ -2873,6 +2876,7 @@ AC_OUTPUT(
asn1/x509if/Makefile
asn1/x509sat/Makefile
asn1/x721/Makefile
+ capchild/Makefile
doc/Makefile
docbook/Makefile
epan/Makefile