aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2013-11-30 15:42:14 +0000
committerMichael Mann <mmann78@netscape.net>2013-11-30 15:42:14 +0000
commitd1e4422a4abc3667351286b13a4224fda65ba26b (patch)
tree7e930d553c4e4179e4936dbfb37fbec76991f456 /codecs/CMakeLists.txt
parent021efe411cab62e2757c04d6a84e459ede7ef35d (diff)
Add G.722, G.726 and SBC codecs. G.722 and G.726 are from bug 5619 (https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5619) and SBC is from bug 7893 (https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7893).
Codecs are added, but (intentionally) not hooked to the RTP player as a "more generic architecture" is desired. There are some discussions in bug 7893 on how to do this. One thing to add would be how to handle codecs that may not be supported on all platforms. Should the codec not be "registered" at all (with a #define over the whole module) or should it's register functions be stubbed (with a #define in each function that requires a non-supported library) svn path=/trunk/; revision=53676
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 8c7c39e877..723d891510 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -24,6 +24,9 @@
set(CODECS_FILES
G711a/G711adecode.c
G711u/G711udecode.c
+ G722/G722decode.c
+ G726/G726decode.c
+ SBC/SBC.c
)
add_library(codecs STATIC