aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>1999-09-17 04:38:23 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>1999-09-17 04:38:23 +0000
commitff20b92b67d90a1e14ef73fde3300cec25c54932 (patch)
tree9b6e211dbaeb2b6cf63de884a86f9b9f2b637e9a /Makefile.am
parent7b6a195ea3c76500f0fb6210cb5a1d069c362410 (diff)
Fixed randpkt so it isn't linked to X11 libs. Removed randpkt from default
target list, so a 'make randpkt' is required if you want to build it. svn path=/trunk/; revision=684
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f748d6c2c..4af7d9e06e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.72 1999/09/14 08:06:22 guy Exp $
+# $Id: Makefile.am,v 1.73 1999/09/17 04:38:14 gram Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -22,7 +22,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-bin_PROGRAMS = ethereal randpkt
+bin_PROGRAMS = ethereal
man_MANS = ethereal.1
@@ -157,11 +157,11 @@ ps.c: print.ps rdps
rdps: rdps.c
$(CC) -o rdps $(srcdir)/rdps.c
-randpkt_SOURCES = \
- randpkt.c
+randpkt.o: randpkt.c
+ $(CC) -DHAVE_CONFIG_H `glib-config --cflags` -c $(srcdir)/randpkt.c
-randpkt_DEPENDENCIES = wiretap/libwiretap.a
-randpkt_LDADD = wiretap/libwiretap.a
+randpkt: randpkt.o wiretap/libwiretap.a
+ $(LINK) -o randpkt randpkt.o wiretap/libwiretap.a `glib-config --libs`
DISTCLEANFILES = \
rdps \