aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-02-07 11:14:52 -0800
committerGerald Combs <gerald@wireshark.org>2014-02-07 23:03:03 +0000
commitf966980937abd4899a9c43329041bb00798ab18e (patch)
treee31210350fa778765b6d2d4711fc5cc6c27f2aae /Makefile.am
parent217f9fd0d9f2d6a9084da3fc945cce001414eea3 (diff)
Replace "svn" with "git" all over the place.
Rename "SVNPATH" to "GITBRANCH" since that seems more appropriate. Rename "svnversion.h" to "version.h" as Evan suggested. Update some URLs. In make-version.pl, make sure we don't set an improper upstream branch name. Use the number of commits + short hash from `git describe` for package names by default. Change-Id: I922bba8d83eabdf49284a119f55b4076bc469b96 Reviewed-on: https://code.wireshark.org/review/139 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b2277716a..5df045c092 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -632,7 +632,7 @@ am__v_PERL_ = $(am__v_PERL_@AM_DEFAULT_V@)
am__v_PERL_0 = @echo " PERL " $@;
am__v_PERL_1 =
-svnversion.h: FORCE
+version.h: FORCE
$(AM_V_PERL)$(PERL) $(srcdir)/make-version.pl $(srcdir)
#
@@ -655,7 +655,7 @@ CLEANFILES = \
vgcore.*
#
-# We have to remove svnversion.h with "make distclean", as, otherwise,
+# We have to remove version.h with "make distclean", as, otherwise,
# "make distcheck" fails. We still need to make the tarballs work
# even if you do "make distclean" and try to rebuild; that's a work in
# progress.
@@ -666,7 +666,7 @@ CLEANFILES = \
#
DISTCLEANFILES = \
ps.c \
- svnversion.h
+ version.h
MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \