aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichal Labedzki <michal.labedzki@tieto.com>2015-02-14 19:10:21 +0100
committerMichal Labedzki <michal.labedzki@tieto.com>2015-04-08 09:57:24 +0000
commitb99cf21c2546bc8260d50f17e60ab614092dac24 (patch)
tree174ffadfa3b220192e64244f9d17fdfb1e0a80bf /Makefile.am
parentf3d2cb5881f320386ca8c4af26053121811edbec (diff)
extcap: Add support for Android - androiddump
androiddump is extcap program that can be used with Android devices (need Android SDK in system PATH). Supported is Logcat/Logger logs and Bluetooth interfaces for all Android to this day (Lollipop). Please note that it will work also for FirefoxOS. Interfaces: 1. Logcat Main (binary or text) 2. Logcat System (binary or text) 3. Logcat Events (binary or text) 4. Logcat Radio (binary or text) 5. Logcat Crash (text; Lollipop) 6. Bluetooth Hcidump (<Kitkat) 7. Bluetooth Bluedroid External Parser (Kitkat) 8. Bluetooth BtsnoopNet (Lollipop) Change-Id: I26e4cd1a37a6af805f8b932399b4aa44ee7b5a80 Reviewed-on: https://code.wireshark.org/review/7475 Petri-Dish: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Michal Labedzki <michal.labedzki@tieto.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 12967ed90b..384a7697e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,10 +42,11 @@ bin_PROGRAMS = \
@dumpcap_bin@ \
@reordercap_bin@ \
@rawshark_bin@ \
+ @androiddump_bin@ \
@echld_test_bin@
EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap \
- mergecap dftest randpkt text2pcap dumpcap reordercap rawshark \
+ mergecap dftest randpkt text2pcap dumpcap reordercap rawshark androiddump \
echld_test
#
@@ -532,6 +533,21 @@ rawshark_LDADD = \
rawshark_CFLAGS = $(AM_CLEAN_CFLAGS)
+if ENABLE_STATIC
+androiddump_LDFLAGS = -Wl,-static -all-static
+else
+androiddump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link androiddump.
+androiddump_LDADD = \
+ wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ @SOCKET_LIBS@
+
+androiddump_CFLAGS = $(AM_CLEAN_CFLAGS)
+
# Libraries with which to link text2pcap.
text2pcap_LDADD = \
wsutil/libwsutil.la \