aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>1999-08-01 04:28:20 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>1999-08-01 04:28:20 +0000
commitb2f932c1dbb6180a3b4a86c7510ef4beff814bb0 (patch)
tree4b9c007a4f6bbfa27c0c7f9cad2a1e7800c30863 /Makefile.am
parentc31abd81fa1fa78b0ac19d0b1de3d492a016768c (diff)
Changed the display filter scanner from GLIB's GScanner to lex. The code
as it standed depends on your lex being flex, but that only matters if you're a developer. The distribution will include the dfilter-scanner.c file, so that if the user doesn't modify dfilter-scanner.l, he won't need flex to re-create the *.c file. The new lex scanner gives me better syntax checking for ether addresses. I thought I could get by using GScanner, but it simply wasn't powerful enough. All operands have English-like abbreviations and C-like syntax: and, && ; or, || ; eq, == ; ne, != ; , etc. I removed the ETHER_VENDOR type in favor of letting the user use the [x:y] notation: ether.src[0:3] == 0:6:29 instead of ether.srcvendor == 00:06:29 I implemented the IPXNET field type; it had been there before, but was not implemented. I chose to make it use integer values rather than byte ranges, since an IPX Network is 4 bytes. So a display filter looks like this: ipx.srcnet == 0xc0a82c00 rather than this: ipx.srcnet == c0:a8:2c:00 I can supposrt the byte-range type IPXNET in the future, very trivially. I still have more work to do on the parser though. It needs to check ranges when extracting byte ranges ([x:y]) from packets. And I need to get rid of those reduce/reduce errors from yacc! svn path=/trunk/; revision=414
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 990d54de17..4398c21e00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,7 @@ ethereal_SOURCES = \
column.h \
config.h \
dfilter-grammar.y \
+ dfilter-scanner.l \
dfilter.c \
dfilter.h \
display.c \
@@ -110,6 +111,7 @@ ethereal_SOURCES = \
EXTRA_ethereal_SOURCES = \
dfilter-grammar.c \
dfilter-grammar.h \
+ dfilter-scanner.c \
packet-snmp.c \
snprintf.c \
snprintf.h \
@@ -149,7 +151,6 @@ EXTRA_DIST = \
README.tru64 \
README.win32 \
rdps.c \
- ylwrap \
VERSION
SUBDIRS = wiretap @SUBDIRS@