aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-12-31 22:57:44 +0000
committerGerald Combs <gerald@wireshark.org>2012-12-31 22:57:44 +0000
commit7e30804155d96ffdea5914f1372d9f20d1ee5b18 (patch)
tree6052907569af1e01f252541a700ee55bfb52bab0 /Makefile.am
parent4ecf61b0df0fafd0e5c7f138c6d244e487776171 (diff)
Automake's "dummy.cpp" trick is all-or-nothing. Instead of forcing
everyone to use a c++ compiler conditionally link with -lstdc++ and hope for the best. svn path=/trunk/; revision=46879
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c03717d661..e959f24d98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -367,7 +367,11 @@ wireshark_LDADD = \
wireshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
if HAVE_WIRESHARK_CPP
-nodist_EXTRA_wireshark_SOURCES = dummy.cpp
+# Ideally we could trigger automatic c++ linking here with
+# nodist_EXTRA_wireshark_SOURCES = dummy.cpp
+# Unfortunately that check is done by automake and not configure
+# c++ linking for Wireshark at all times.
+wireshark_LDFLAGS += -lstdc++
endif
if ENABLE_STATIC