aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-03-08 23:40:37 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-03-08 23:40:37 +0000
commit6eb2e2899a60ce14d03bab0e320a21314b118bba (patch)
tree9c85f0daa6aafcad0afb711db43d6f4dc619005d /Makefile.am
parentcfbba71508f74802f57633b2be2e14bce87f07fb (diff)
freekdesktop.org says all themes must fall back to 'hicolor' if they don't find
a theme-specific icon (and as such hicolor is where applications should install their icons). So: don't install some of our icons in the gnome area, install them all in hicolor. While we're at it, go ahead and install all the icon sizes we have. If we're on SuSE, use their desktop-file-updater macro; without that they won't recognize our desktop file. Fix bug which prevented the MIME database from being updated if our install prefix is not /usr . svn path=/trunk/; revision=48204
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 1dec9c5d5d..7d57b72d0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1027,23 +1027,19 @@ patch-bzip2: distdir
# What we (probably) should do is check `pkg-config --variable=prefix gtk+-2.0` to know where
# to install this stuff...
install_desktop_files:
- mkdir -p $(DESTDIR)/usr/share/{icons/gnome/{16x16,32x32,48x48,256x256}/mimetypes,mime/packages,applications}
+ mkdir -p $(DESTDIR)/usr/share/{mime/packages,applications}
install -m 644 -T wireshark-mime-package.xml $(DESTDIR)/usr/share/mime/packages/wireshark.xml
if test x$(DESKTOP_FILE_INSTALL) != x ; then \
$(DESKTOP_FILE_INSTALL) --dir $(DESTDIR)/usr/share/applications wireshark.desktop; \
else \
install -m 644 -T wireshark.desktop $(DESTDIR)/usr/share/applications/wireshark.desktop; \
fi
- mkdir -p $(DESTDIR)/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,256x256}/apps
- install -m 644 image/wsicon16.png $(DESTDIR)/usr/share/icons/hicolor/16x16/apps/wireshark.png
- install -m 644 image/wsicon32.png $(DESTDIR)/usr/share/icons/hicolor/32x32/apps/wireshark.png
- install -m 644 image/wsicon48.png $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/wireshark.png
- install -m 644 image/wsicon64.png $(DESTDIR)/usr/share/icons/hicolor/64x64/apps/wireshark.png
- install -m 644 image/wsicon256.png $(DESTDIR)/usr/share/icons/hicolor/256x256/apps/wireshark.png
- install -m 644 -T image/WiresharkDoc-16.png $(DESTDIR)/usr/share/icons/gnome/16x16/mimetypes/application-wireshark-doc.png
- install -m 644 -T image/WiresharkDoc-32.png $(DESTDIR)/usr/share/icons/gnome/32x32/mimetypes/application-wireshark-doc.png
- install -m 644 -T image/WiresharkDoc-48.png $(DESTDIR)/usr/share/icons/gnome/48x48/mimetypes/application-wireshark-doc.png
- install -m 644 -T image/WiresharkDoc-256.png $(DESTDIR)/usr/share/icons/gnome/256x256/mimetypes/application-wireshark-doc.png
+ for size in 16 32 48 64 256 ; \
+ do \
+ mkdir -p $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/{apps,mimetypes} ; \
+ install -m 644 image/wsicon$${size}.png $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/wireshark.png ; \
+ install -m 644 -T image/WiresharkDoc-$${size}.png $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/mimetypes/application-wireshark-doc.png ; \
+ done
@echo "Don't forget to run \"update-desktop-database\" and \"update-mime-database /usr/share/mime\""
# Used by svr4-package and osx-package
@@ -1076,7 +1072,7 @@ rpm-package: dist
cd $(rpm_topdir) ; \
mkdir -p BUILD RPMS SOURCES SRPMS; \
cd SOURCES ; \
- ln -s ../../../$(distdir).tar.bz2 ; \
+ ln -sf ../../../$(distdir).tar.bz2 ; \
cd .. ; \
rpmbuild --define "_topdir `cd . && pwd`" --define "_prefix $(prefix)" --clean -ba SPECS/wireshark.spec && \
echo "Package successfully built in `pwd`/RPMS." && \