aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2000-01-08 19:37:11 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2000-01-08 19:37:11 +0000
commit69edc78327d2ae554c401499b7ef55191f832364 (patch)
tree1b7bdfe36149140edc1e29d267b46c058ed3f248 /Makefile.am
parent7a943b7810c17ea18c780bbf5d101a27b99fe5b9 (diff)
I finally got autoconf, automake, and the plugins to behave together.
The distro is buildable finally. I had to change "plugins/gryphon" from a separately configured (i.e., "./configure") package to a member of the main ethereal autoconf package so that PLUGIN_DIR could be passed to plugins/gryphon/Makefile.am. In doing so, I had to get rid of plugins/gryphon/config.h which had PACKAGE and VERSION #defined, the latter of which was actually used in packet-gryphon.c. So I moved those two #defines into a new file, plugins/gryphon/moduleinfo.h. svn path=/trunk/; revision=1438
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 23 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b542ed130..025afe59cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.144 2000/01/07 09:10:12 guy Exp $
+# $Id: Makefile.am,v 1.145 2000/01/08 19:36:10 gram Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -252,17 +252,30 @@ EXTRA_ethereal_SOURCES = \
inet_pton.c \
inet_ntop.c
-ethereal_DEPENDENCIES = @SNPRINTF_O@ @STRERROR_O@ \
- @STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
- wiretap/libwiretap.a gtk/libui.a \
- @LIBLTDL@ \
+# Optional objects that I know how to build. These will be
+# linked into the ethereal executable.
+ethereal_optional_objects = @SNPRINTF_O@ @STRERROR_O@ @STRNCASECMP_O@ @MKSTEMP_O@ \
+ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+
+# Additional libs that I know how to build. These will be
+# linked into the ethereal executable.
+ethereal_additional_libs = wiretap/libwiretap.a gtk/libui.a
+
+# This is the automake dependency variable for the executable
+ethereal_DEPENDENCIES = \
+ $(ethereal_optional_objects) \
+ $(ethereal_additional_libs) \
+ @LIBTDL@
plugins/gryphon/gryphon.la
-ethereal_LDADD = @SNPRINTF_O@ @STRERROR_O@ \
- @STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
- wiretap/libwiretap.a gtk/libui.a \
- @SNMP_A@ \
- @LIBLTDL@ "-dlopen" self \
+
+# This automake variable adds to the link-line for the executable
+ethereal_LDADD = \
+ $(ethereal_optional_objects) \
+ $(ethereal_additional_libs) \
+ @SNMP_A@ \
+ @LIBLTDL@ "-dlopen" self \
"-dlopen" plugins/gryphon/gryphon.la
+
ethereal_LDFLAGS = -export-dynamic