aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2008-07-01 13:39:09 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2008-07-01 13:39:09 +0000
commit673a730de35b6d5cfc3db375686cb0ee6a9998a6 (patch)
tree2833f25e7a12a69b78714b006d0cceaa8eb9c856 /Makefile.am
parentbd0598cc559d8451c47824ce71a1952d0268391c (diff)
Added a new make target, osx-app, to build only the app and not the dmg.
This is usefull when using the app locally. svn path=/trunk/; revision=25646
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c028ee398..a54ebd435b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -967,18 +967,23 @@ debian-package: debian/rules
fi
# XXX - This assumes we're building from the source directory.
-osx-package: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) packaging/macosx/Info.plist
+osx-app: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) packaging/macosx/Info.plist
@if test x$(HAVE_OSX_PACKAGING) = xyes ; then \
rm -rf $(stagedir) ; \
$(MAKE) DESTDIR=$(stagedir) install; \
cd $(srcdir)/packaging/macosx ; \
./osx-app.sh -bp ../staging/$(PACKAGE).inst/$(bindir) ; \
- ./osx-dmg.sh ; \
else \
echo "Error: OS X packaging tools not found." ; \
echo "Package build abandoned." ; \
fi
+osx-package: osx-app
+ @if test x$(HAVE_OSX_PACKAGING) = xyes ; then \
+ cd $(srcdir)/packaging/macosx ; \
+ ./osx-dmg.sh ; \
+ fi
+
clean-local:
rm -rf $(top_stagedir)