aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-02-18 23:55:41 +0000
committerGuy Harris <guy@alum.mit.edu>2012-02-18 23:55:41 +0000
commit530c8c53902c2da8f49551c6874c89e319ba1534 (patch)
tree3af372a25e0c8420185112cb18ed6a5020ed0746 /Makefile.am
parentb42cfb1ff1d055da56326895484a0723f514aef4 (diff)
Create a libui (static) library in the ui directory, which contains the
object files from all the source files in the ui directory (but not in its subdirectories), and link the programs that need it with them. This cleans things up a little bit, and may also fix the Windows build. svn path=/trunk/; revision=41061
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 192dd67873..b4648fda78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -386,6 +386,7 @@ endif
# @GTK_LIBS@ (as those are also needed for X applications, and GTK+
# applications are X applications).
wireshark_LDADD = \
+ ui/libui.a \
ui/gtk/libgtkui.a \
ui/gtk/libgtkui_dirty.a \
codecs/libcodec.a \
@@ -416,6 +417,7 @@ endif
# Libraries and plugin flags with which to link tshark.
tshark_LDADD = \
+ ui/libui.a \
wiretap/libwiretap.la \
epan/libwireshark.la \
wsutil/libwsutil.la \
@@ -443,6 +445,7 @@ endif
# Libraries and plugin flags with which to link rawshark.
rawshark_LDADD = \
+ ui/libui.a \
wiretap/libwiretap.la \
epan/libwireshark.la \
wsutil/libwsutil.la \
@@ -509,6 +512,7 @@ randpkt_CFLAGS = $(AM_CLEAN_CFLAGS)
# Libraries and plugin flags with which to link dftest.
dftest_LDADD = \
+ ui/libui.a \
wiretap/libwiretap.la \
wsutil/libwsutil.la \
epan/libwireshark.la \
@@ -955,7 +959,7 @@ endif
endif
-DIST_SUBDIRS = asn1 codecs doc epan ui/gtk help packaging plugins tools wiretap wsutil docbook
+DIST_SUBDIRS = asn1 codecs doc epan ui ui/gtk help packaging plugins tools wiretap wsutil docbook
if HAVE_PLUGINS
SUBDIRS = tools wsutil wiretap epan plugins packaging help @wireshark_SUBDIRS@ . doc
@@ -1077,6 +1081,7 @@ checkapi_local:
checkapi: checkapi_local
cd wiretap && $(MAKE) checkapi
cd codecs && $(MAKE) checkapi
+ cd ui && $(MAKE) checkapi
cd ui/gtk && $(MAKE) checkapi
## cd epan && $(MAKE) checkapi
## cd epan/crypt && $(MAKE) checkapi