aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
committerGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
commit45babe7bb5b9348a9ba6cad2e8aed26bfd10e3a3 (patch)
treecceb02d34be8c7f835ac3479456855d35e9e6e73 /Makefile.am
parentc91afab6c988371f877216e5687f3a4c7f8ad13f (diff)
Integrate libtool/libltdl with the plugin code. Add libtool and libltdl
to the distribution. svn path=/trunk/; revision=1379
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 27 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ca7c40b6c3..ecdb615006 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.138 1999/12/22 20:12:38 guy Exp $
+# $Id: Makefile.am,v 1.139 1999/12/26 22:37:19 gerald Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -31,6 +31,15 @@ sysconf_DATA = manuf
# Any POSIX-compatible YACC should honor the -p flag
YFLAGS=-d -p dfilter_
+## use @LIBLTDL@ because some broken makes do not accept macros in targets
+## we can only do this because our LIBLTDL does not contain ${top_builddir}
+@LIBLTDL@: libtool libltdl/libtool libltdl/config.h \
+ $(srcdir)/libltdl/ltdl.c $(srcdir)/libltdl/ltdl.h
+ (cd libltdl; $(MAKE) `echo $(LIBLTDL) | sed 's,.*\.\./libltdl/,,g'`)
+# Without the following line, the check may fail if libltdl/libtool is
+# removed after libltdl is configured
+libltdl/libtool libltdl/config.h:
+
DISSECTOR_SOURCES = \
packet-aarp.c \
packet-afs.c \
@@ -240,12 +249,18 @@ EXTRA_ethereal_SOURCES = \
inet_ntop.c
ethereal_DEPENDENCIES = @SNPRINTF_O@ @STRERROR_O@ \
-@STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
-wiretap/libwiretap.a gtk/libui.a
+ @STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
+ wiretap/libwiretap.a gtk/libui.a \
+ @LIBLTDL@ \
+ plugins/gryphon/gryphon.la
ethereal_LDADD = @SNPRINTF_O@ @STRERROR_O@ \
-@STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
-wiretap/libwiretap.a gtk/libui.a \
-@SNMP_A@
+ @STRNCASECMP_O@ @MKSTEMP_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@\
+ wiretap/libwiretap.a gtk/libui.a \
+ @SNMP_A@ \
+ @LIBLTDL@ "-dlopen" self \
+ "-dlopen" plugins/gryphon/gryphon.la
+ethereal_LDFLAGS = -export-dynamic
+
#
# Build "register.c", which contains a function "register_all_protocols()"
@@ -341,7 +356,7 @@ EXTRA_DIST = \
dist-hook:
@rm -f $(distdir)/register.c
-SUBDIRS = wiretap gtk @ethereal_SUBDIRS@
+SUBDIRS = wiretap gtk plugins libltdl @ethereal_SUBDIRS@
ethereal.1: ethereal doc/ethereal.pod.template
(cd doc ; \
@@ -349,3 +364,8 @@ ethereal.1: ethereal doc/ethereal.pod.template
dfilter-scanner.c : dfilter-scanner.l
$(LEX) -Pdfilter_ -t $(srcdir)/dfilter-scanner.l > dfilter-scanner.c
+
+INCLUDES = -I$(srcdir)/libltdl
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status --recheck