aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2011-11-17 00:19:03 +0000
committerGerald Combs <gerald@wireshark.org>2011-11-17 00:19:03 +0000
commit3f12c48aced9cc097cd792a4d4ac37d152fa2be4 (patch)
treeb3d4e1e923b43b0d867775a85b00f9a8e4ed27df /Makefile.am
parent8a630d8e37464518dfe7c5a9943ad612d0544b89 (diff)
Add an SVN_REVISION variable to config.nmake. This can be used to
retrieve our SVN revision in releases. Use make-version.pl to set all version information. Be more explicit about the tasks it performs: - Fetching the SVN revision which corresponds to our code. The revision can be fetched via "svn info", "git svn info", SubWCRev", config.nmake, or by prodding .svn. - Setting the version numbers (the "major.minor.micro" triplet). - Setting the release information (revision/build number, local build identifier) Remove the "is_release" configuration option and dist-hook target. When run with a "--set-*" option or no options make sure we leave a valid svnversion.h behind. svn path=/trunk/; revision=39891
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 0 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 33892f658c..29eb97f877 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1028,15 +1028,3 @@ checkapi: checkapi_local
cd ../dissectors && $(MAKE) checkapi
cd ../../plugins && $(MAKE) checkapi
cd ../wsutil && $(MAKE) checkapi
-
-# When we build a release tarball, tell make-version that it is such. This
-# prevents make-version from looking for SVN details in the source tarball,
-# failing, and then labelling the build as from "SVN version unknown."
-dist-hook:
- if test -f $(top_srcdir)/version.conf -a ! -f $(top_distdir)/version.conf ; then \
- cp $(top_srcdir)/version.conf $(top_distdir); \
- if grep "^is_release: *1" $(top_distdir)/version.conf ; then :; \
- else \
- echo "is_release: 1" >> $(top_distdir)/version.conf; \
- fi ; \
- fi