aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-03-01 15:31:45 -0800
committerAnders Broman <a.broman58@gmail.com>2018-03-02 05:22:20 +0000
commit1a0987904fa571dc5abce03726e4ca3e17793574 (patch)
tree59b7bfe30517005b046bddb9fcae2315f48570fa /Makefile.am
parentbf4c2fd82b30d8b088fcb1235263dce9173d4cd7 (diff)
Generalize our process spawning code.
Move the contents of extcap_spawn to ws_pipe. Rename various extcap_* prefixes to ws_pipe_*. Open stdin when we spawn processes. Change-Id: I9286295443ee955bb6328b0ed6f945ee0bb2a798 Reviewed-on: https://code.wireshark.org/review/26216 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f93cad4c15..7d9ca8de47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -380,8 +380,7 @@ SHARK_COMMON_SRC = \
frame_tvbuff.c \
sync_pipe_write.c \
extcap.c \
- extcap_parser.c \
- extcap_spawn.c
+ extcap_parser.c
# wireshark specifics
WIRESHARK_COMMON_SRC = \
@@ -722,7 +721,6 @@ noinst_HEADERS = \
conditions.h \
extcap.h \
extcap_parser.h \
- extcap_spawn.h \
fileset.h \
frame_tvbuff.h \
ringbuffer.h \