aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2003-01-06 02:24:57 +0000
committerGuy Harris <guy@alum.mit.edu>2003-01-06 02:24:57 +0000
commit0551b7030f503fc8bd811b46f8b5742e4c197c48 (patch)
tree2025816e192f7c66be50704ddf234a093d1e3f86 /Makefile.am
parent28e7a235690f1ed51fd7206a3fa0f5fbf2f8dd30 (diff)
Add an X.29 dissector.
The Q bit in X.25 doesn't mean "this is QLLC traffic", it's just a "this packet is special" indication. Have the X.25 dissector pass as the "private_data" pointer a pointer to a gboolean indicating whether the Q bit was set or not. Replace the "decode non-Q-bit traffic as SNA" option with a "decode traffic as QLLC/SNA if we didn't see the Call Request packet and thus don't know what it is" option, which hands traffic to the QLLC dissector for that traffic. Have the QLLC dissector hand traffic to the SNA dissector if the Q bit isn't set. Arrange that we determine whether the Q bit is set regardless of whether we're building the protocol tree or not. If we don't just dissect traffic as QLLC/SNA if we didn't see the Call Request packet, check not only for 0x45 (as an indication that it's probably IP), check also for NLPID_ISO8473_CLNP and treat that as an indication that it's probably OSI CLNP. svn path=/trunk/; revision=6854
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f268d08753..2b33c78c6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.533 2003/01/03 22:31:23 guy Exp $
+# $Id: Makefile.am,v 1.534 2003/01/06 02:24:56 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -381,6 +381,7 @@ DISSECTOR_SRC = \
packet-wtp.c \
packet-x11.c \
packet-x25.c \
+ packet-x29.c \
packet-xdmcp.c \
packet-xot.c \
packet-xyplex.c \