aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-01-02 01:17:07 +0000
committerGerald Combs <gerald@wireshark.org>2013-01-02 01:17:07 +0000
commita689b032f68453a2127c036fcbd3573f0298e289 (patch)
tree5830ceb90bb20073eaab5b575ee44ccf74fcdfe1 /Makefile.am
parentb62d650ba16c157b334537a466e1ffc16d40e006 (diff)
Make sure we don't try to distribute nonexistent files.
svn path=/trunk/; revision=46888
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 639a71acf4..35e0ebe6b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -372,9 +372,13 @@ wireshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
# Unfortunately that check is done by automake and not configure.
# We do the following to try to avoid c++ linking for Wireshark at
# all times.
-nodist_EXTRA_wireshark_cxx_SOURCES = dummy.cpp
+nodist_EXTRA_wireshark_c_SOURCES = dummy.c
+wireshark_c_SOURCES =
wireshark_c_CFLAGS = $(wireshark_CFLAGS)
wireshark_c_LDFLAGS = $(wireshark_LDFLAGS)
+
+nodist_EXTRA_wireshark_cxx_SOURCES = dummy.cpp
+wireshark_cxx_SOURCES =
wireshark_cxx_CFLAGS = $(wireshark_CFLAGS)
wireshark_cxx_LDFLAGS = $(wireshark_LDFLAGS)