aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-02-22 20:03:36 +0000
committerGerald Combs <gerald@wireshark.org>2008-02-22 20:03:36 +0000
commit4f996bd670188239ec26d78461b1c4d69977e808 (patch)
tree2a5dd9b8f005bc93f34698f5609ef7190a44ddd7 /Makefile.am
parent28394977662db1032b0fa9aadc3ffb7c946c9640 (diff)
Use the docbook CSS for the man pages (which assumes your version of
pod2html supports the "--css" flag). Package up the CSS file, and add missing HTML files where needed. svn path=/trunk/; revision=24428
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d6792e269..ea37737a10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,7 @@ idl2wrs: tools/idl2wrs.sh Makefile
pkgdata_DATA = AUTHORS-SHORT COPYING manuf services wireshark.html \
tshark.html wireshark-filter.html capinfos.html editcap.html \
idl2wrs.html mergecap.html text2pcap.html dumpcap.html \
- rawshark.html cfilters colorfilters dfilters smi_modules
+ rawshark.html ws.css cfilters colorfilters dfilters smi_modules
#
# Install the Diameter DTD and XML files in the "diameter" subdirectory
@@ -840,43 +840,46 @@ rawshark.1: doc/rawshark.pod
(cd doc ; \
$(MAKE) ../rawshark.1 )
-wireshark.html: doc/wireshark.pod AUTHORS-SHORT-FORMAT
+ws.css: docbook/ws.css
+ cp docbook/ws.css .
+
+wireshark.html: doc/wireshark.pod AUTHORS-SHORT-FORMAT ws.css
(cd doc ; \
$(MAKE) ../wireshark.html )
-tshark.html: doc/tshark.pod
+tshark.html: doc/tshark.pod ws.css
(cd doc ; \
$(MAKE) ../tshark.html )
-wireshark-filter.html: tshark doc/wireshark-filter.pod.template
+wireshark-filter.html: tshark doc/wireshark-filter.pod.template ws.css
(cd doc ; \
$(MAKE) ../wireshark-filter.html )
-capinfos.html: doc/capinfos.pod
+capinfos.html: doc/capinfos.pod ws.css
(cd doc ; \
$(MAKE) ../capinfos.html )
-editcap.html: doc/editcap.pod
+editcap.html: doc/editcap.pod ws.css
(cd doc ; \
$(MAKE) ../editcap.html )
-idl2wrs.html: doc/idl2wrs.pod
+idl2wrs.html: doc/idl2wrs.pod ws.css
(cd doc ; \
$(MAKE) ../idl2wrs.html )
-mergecap.html: doc/mergecap.pod
+mergecap.html: doc/mergecap.pod ws.css
(cd doc ; \
$(MAKE) ../mergecap.html )
-text2pcap.html: doc/text2pcap.pod
+text2pcap.html: doc/text2pcap.pod ws.css
(cd doc ; \
$(MAKE) ../text2pcap.html )
-dumpcap.html: doc/dumpcap.pod
+dumpcap.html: doc/dumpcap.pod ws.css
(cd doc ; \
$(MAKE) ../dumpcap.html )
-rawshark.html: doc/rawshark.pod
+rawshark.html: doc/rawshark.pod ws.css
(cd doc ; \
$(MAKE) ../rawshark.html )