aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-06-23 08:39:07 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-06-23 08:39:07 +0000
commit9fac20d9ecb25a1d6164200c82f1bf766346da81 (patch)
tree88a6cbee3068439280427c5db1ec787f4bffa956 /Makefile.am
parenta6bf4adb74ab589d98d6441349727507cbc2c1b1 (diff)
Build and install the HTMLized man pages on UN*X.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@11217 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 32 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 168d1ebdc3..e324318e3c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.735 2004/06/22 00:40:02 guy Exp $
+# $Id: Makefile.am,v 1.736 2004/06/23 08:39:06 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -73,7 +73,9 @@ EXTRA_SCRIPTS = idl2eth
# Ethereal configuration files are put in $(pkgdatadir). It currently
# contains the "AUTHORS-SHORT" and "manuf" files and a "diameter" directory.
#
-pkgdata_DATA = AUTHORS-SHORT manuf
+pkgdata_DATA = AUTHORS-SHORT manuf ethereal.html tethereal.html \
+ ethereal-filter.html editcap.html idl2eth.html mergecap.html \
+ text2pcap.html
#
# Install the Diameter DTD and XML files in the "diameter" subdirectory
@@ -575,6 +577,34 @@ text2pcap.1: doc/text2pcap.pod
(cd doc ; \
$(MAKE) ../text2pcap.1 )
+ethereal.html: ethereal doc/ethereal.pod AUTHORS-SHORT
+ (cd doc ; \
+ $(MAKE) ../ethereal.html )
+
+tethereal.html: tethereal doc/tethereal.pod
+ (cd doc ; \
+ $(MAKE) ../tethereal.html )
+
+ethereal-filter.html: tethereal doc/ethereal-filter.pod.template
+ (cd doc ; \
+ $(MAKE) ../ethereal-filter.html )
+
+editcap.html: doc/editcap.pod
+ (cd doc ; \
+ $(MAKE) ../editcap.html )
+
+idl2eth.html: doc/idl2eth.pod
+ (cd doc ; \
+ $(MAKE) ../idl2eth.html )
+
+mergecap.html: doc/mergecap.pod
+ (cd doc ; \
+ $(MAKE) ../mergecap.html )
+
+text2pcap.html: doc/text2pcap.pod
+ (cd doc ; \
+ $(MAKE) ../text2pcap.html )
+
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status --recheck