aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-03-26 21:01:32 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-03-26 21:01:32 +0000
commit483aa2e0796376c5877de8a14baa67eb2ed7cae3 (patch)
treea835ad7be38b9b017963faf579805001de109831 /Makefile.am
parent6c4b5b5929bb2de7e26450603a3dfa5e06524bbf (diff)
Add wsicon128.png to the source distribution.
Install some more icon sizes (24x24 and 128x128) when installing desktop files. svn path=/trunk/; revision=48570
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 60aea02b1c..1a3efe47e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -850,13 +850,13 @@ EXTRA_DIST = \
image/wireshark.rc.in \
image/wiresharkdoc.ico \
image/wiresharkinst.ico \
- image/WiresharkDoc-128.png \
image/WiresharkDoc-16.png \
image/WiresharkDoc-24.png \
- image/WiresharkDoc-256.png \
image/WiresharkDoc-32.png \
image/WiresharkDoc-48.png \
image/WiresharkDoc-64.png \
+ image/WiresharkDoc-128.png \
+ image/WiresharkDoc-256.png \
image/wiretap.rc.in \
image/wsicon.svg \
image/wsicon16.png \
@@ -864,6 +864,7 @@ EXTRA_DIST = \
image/wsicon32.png \
image/wsicon48.png \
image/wsicon64.png \
+ image/wsicon128.png \
image/wsicon256.png \
image/wsicon512.png \
image/wsicon1024.png \
@@ -1018,7 +1019,7 @@ patch-bzip2: distdir
fi
$(am__remove_distdir)
-# Install some desktop files (for use with GNOME and/or freedesktop.org-compliant desktops?)
+# Install some desktop files (for use with GNOME, KDE, or any other freedesktop.org-compliant desktops)
# No, these do not go into $(datarootdir): the desktop won't look for them there.
# Yes, that violate's autofoo's principle of relocatability.
# What we (probably) should do is check `pkg-config --variable=prefix gtk+-2.0` to know where
@@ -1031,7 +1032,7 @@ install_desktop_files:
else \
install -m 644 -T wireshark.desktop $(DESTDIR)/usr/share/applications/wireshark.desktop; \
fi
- for size in 16 32 48 64 256 ; \
+ for size in 16 24 32 48 64 128 256; \
do \
mkdir -p $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/{apps,mimetypes} ; \
install -m 644 image/wsicon$${size}.png $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/wireshark.png ; \