aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2006-11-07 08:41:46 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2006-11-07 08:41:46 +0000
commiteb4d8fc6fa1b4d577ea433e0cffdca1f7f11ea9a (patch)
treedb659fd06199f95bab4e143e340b2999e0267119 /Makefile.am
parentfeec28e1f72bedfb1db732dcedce5d5b9d4042d7 (diff)
albert chin:
version_info.c has: #ifdef HAVE_LIBGCRYPT #include <gcrypt.h> #endif /* HAVE_LIBGCRYPT */ #ifdef HAVE_LIBGNUTLS #include <gnutls/gnutls.h> #endif /* HAVE_LIBGNUTLS */ However, Makefile.am doesn't include the necessary CPPFLAGS/LDFLAGS to resolve symbols from the above. Patch attached. Note: dumpcap should not need to be linked to gnutls, but that's a problem with the version infrastructure. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@19853 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a0c19da8d..7ae1fb0aab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -357,7 +357,8 @@ editcap_LDADD = wiretap/libwiretap.la @GLIB_LIBS@
mergecap_LDADD = wiretap/libwiretap.la @GLIB_LIBS@
# Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap \
+ $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS)
#
# Build the version string
@@ -459,6 +460,7 @@ dumpcap_DEPENDENCIES = \
dumpcap_LDADD = \
$(dumpcap_additional_libs) \
@GLIB_LIBS@ \
+ @LIBGCRYPT_LIBS@ \
@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@
#