aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1998-09-16 02:39:15 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1998-09-16 02:39:15 +0000
commitba22fd6da0503da55c5a3e5187b45190609a7af3 (patch)
tree681b71cababcf54c865c4dfa3c52a98b1d793231 /Makefile.am
parentce208ca3f55526cc6816743faf560584461661fe (diff)
Initial revision
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@2 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000000..2c148261ab
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,69 @@
+bin_PROGRAMS = ethereal
+
+man_MANS = ethereal.1
+
+ethereal_SOURCES = \
+ capture.c \
+ ethereal.c \
+ ethertype.c \
+ file.c \
+ filter.c \
+ menu.c \
+ packet.c \
+ packet-arp.c \
+ packet-bootp.c \
+ packet-data.c \
+ packet-dns.c \
+ packet-eth.c \
+ packet-llc.c \
+ packet-lpd.c \
+ packet-ip.c \
+ packet-ipv6.c \
+ packet-ipx.c \
+ packet-ospf.c \
+ packet-ppp.c \
+ packet-raw.c \
+ packet-rip.c \
+ packet-tcp.c \
+ packet-tr.c \
+ packet-trmac.c \
+ packet-udp.c \
+ print.c \
+ ps.c \
+ resolv.c \
+ util.c \
+ capture.h \
+ config.h \
+ ethereal.h \
+ etypes.h \
+ file.h \
+ filter.h \
+ menu.h \
+ packet.h \
+ packet-ipv6.h \
+ packet-ospf.h \
+ packet-rip.h \
+ print.h \
+ ps.h \
+ resolv.h \
+ snprintf.h \
+ util.h
+
+ps.c: print.ps rdps
+ ./rdps print.ps ps.c
+
+rdps: rdps.c
+ $(CC) -o rdps rdps.c
+
+EXTRA_ethereal_SOURCES = @SNPRINTF_C@
+ethereal_DEPENDENCIES = @SNPRINTF_O@
+LDADD = @SNPRINTF_O@
+
+EXTRA_DIST = \
+ ethereal.1 \
+ snprintf.c \
+ rdps.c \
+ print.ps \
+ image/icon-excl.xpm \
+ doc/Makefile \
+ doc/ethereal.pod