aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2011-10-25 19:04:26 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2011-10-25 19:04:26 +0000
commitb281289d662e20ee13d4b75c15dddb14a7ab9e53 (patch)
treeb4ff79919f3463219fabd89a14b7640af02916c0 /Makefile.am
parentd4fc197d350da79cd9c8bb7236a0972fbdbc8a1c (diff)
In dist-hook, don't try to copy version.conf if it already exists in the
destination directory. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@39572 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 682c2d02ec..17bc92451a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1033,7 +1033,7 @@ checkapi: checkapi_local
# prevents make-version from looking for SVN details in the source tarball,
# failing, and then labelling the build as from "SVN version unknown."
dist-hook:
- if test -f $(top_srcdir)/version.conf; then \
+ if test -f $(top_srcdir)/version.conf -a ! -f $(top_distdir)/version.conf ; then \
cp $(top_srcdir)/version.conf $(top_distdir); \
echo "is_release: 1" >> $(top_distdir)/version.conf; \
fi