aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-03 00:42:00 +0100
committerJoão Valverde <j@v6e.pt>2017-09-15 10:11:55 +0000
commite7ef19efc0e928b50644b37772ccbf176e74f766 (patch)
tree1d6a4bb5163e5b094d5c5879d96b961113258315 /Makefile.am
parentc52a702ae81b1ae7311a8b58e625f86fb211e7c5 (diff)
autotools: Initial work to install headers for the benefit of plugins
Install public headers required to build plugins for libwireshark (taps and dissectors). The source tree is organized to serve the CLI/GUI parts of wireshark. Plugins are built in tree. This change is intende to allow plugins to be built out-of-tree but we want to avoid dumping all headers into /usr/include. To be continued incrementally to fix errors and omissions. Change-Id: Iaa0def0ba3de4b456a29114c315544d2d64fa748 Reviewed-on: https://code.wireshark.org/review/23374 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 22 insertions, 31 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c1ebd5fef..b7db8736ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -393,30 +393,15 @@ GENERATED_FILES = $(GENERATED_C_FILES) $(GENERATED_HEADER_FILES)
EXTCAP_COMMON_SRC = \
extcap.c \
- extcap_parser.c \
+ extcap_parser.c \
extcap_spawn.c
-EXTCAP_COMMON_INCLUDES = \
- extcap.h \
- extcap_parser.h \
- extcap_spawn.h
-
# sources common for wireshark, tshark, and rawshark
SHARK_COMMON_SRC = \
cfile.c \
frame_tvbuff.c \
sync_pipe_write.c
-# corresponding headers
-SHARK_COMMON_INCLUDES = \
- cfile.h \
- file.h \
- fileset.h \
- frame_tvbuff.h \
- register.h \
- ws_symbol_export.h \
- ws_attributes.h
-
# wireshark specifics
WIRESHARK_COMMON_SRC = \
$(SHARK_COMMON_SRC) \
@@ -427,15 +412,6 @@ WIRESHARK_COMMON_SRC = \
summary.c \
ws_version_info.c
-# corresponding headers
-WIRESHARK_COMMON_INCLUDES = \
- capture_info.h \
- capture_opts.h \
- globals.h \
- log.h \
- summary.h \
- sync_pipe.h
-
if HAVE_EXTCAP
SHARK_COMMON_SRC += $(EXTCAP_COMMON_SRC)
endif
@@ -761,15 +737,30 @@ dumpcap_LDADD = \
@LIBCAP_LIBS@ \
@LIBNL_LIBS@
+pkginclude_HEADERS = \
+ cfile.h \
+ file.h \
+ register.h \
+ globals.h \
+ log.h \
+ ws_symbol_export.h \
+ ws_attributes.h \
+ ws_diag_control.h
+
# this target needed for distribution only
noinst_HEADERS = \
- $(SHARK_COMMON_INCLUDES) \
- $(EXTCAP_COMMON_INCLUDES) \
- $(WIRESHARK_COMMON_INCLUDES) \
+ capture_info.h \
+ capture_opts.h \
capture_stop_conditions.h \
- conditions.h \
- ringbuffer.h \
- ws_diag_control.h \
+ conditions.h \
+ fileset.h \
+ frame_tvbuff.h \
+ ringbuffer.h \
+ summary.h \
+ sync_pipe.h \
+ extcap.h \
+ extcap_parser.h \
+ extcap_spawn.h \
ws_version_info.h
#