aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-28 17:29:10 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-28 17:29:10 +0000
commitfe16b9835f0e7eb8c4e2a682ab0e82b5aa00bc61 (patch)
treeea060143bfb5e3e51cc25c279b0ff7d3aeec2271 /Makefile.am
parentd0992bf8cd4af994537fb68dae67c1f93bb6906d (diff)
Be a little quieter (and do a little more cleanup) when building RPMs.
svn path=/trunk/; revision=47944
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 619f9082da..8024e3a71c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1048,7 +1048,7 @@ solaris-package: svr4-package
rpm_topdir=`cd $(top_builddir) && pwd`/packaging/rpm
rpm-package: dist
- if test x$(HAVE_RPM) = xyes ; then \
+ @if test x$(HAVE_RPM) = xyes ; then \
cd $(rpm_topdir) ; \
mkdir -p BUILD RPMS SOURCES SRPMS; \
cd SOURCES ; \
@@ -1056,7 +1056,7 @@ rpm-package: dist
cd .. ; \
rpmbuild --define "_topdir `cd . && pwd`" --clean -ba SPECS/wireshark.spec && \
echo "Package successfully built in `pwd`/RPMS." ; \
- rm -f SOURCES/$(distdir).tar.bz2; \
+ rm -f SOURCES/$(distdir).tar.bz2 $(distdir).tar.bz2; \
else \
echo "Error: RPM executable and/or source directory not found." ; \
false; \