aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-28 23:02:38 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-02-28 23:02:38 +0000
commit663e6a6d6b3a3e03677c5fefea3f50e1157c2b7a (patch)
tree170b6fa10fe2cb07c4e02e17668aeaf9966a70f9 /Makefile.am
parent7eac6729d8ce9ed1c9b62167b942fd16691a423b (diff)
Make it so that alternate-prefix RPM builds actually work.
Use the prefix from 'configure' in the RPM (so: to build an RPM which installs in /opt do "./configure --prefix=/opt && make rpm-package"). (Maybe this approach should also be used for the other options in the .spec file.) Only clean up if building the RPM was successful. svn path=/trunk/; revision=47957
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8024e3a71c..a9b72fd5a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1054,9 +1054,9 @@ rpm-package: dist
cd SOURCES ; \
ln -s ../../../$(distdir).tar.bz2 ; \
cd .. ; \
- rpmbuild --define "_topdir `cd . && pwd`" --clean -ba SPECS/wireshark.spec && \
- echo "Package successfully built in `pwd`/RPMS." ; \
- rm -f SOURCES/$(distdir).tar.bz2 $(distdir).tar.bz2; \
+ rpmbuild --define "_topdir `cd . && pwd`" --define "_prefix $(prefix)" --clean -ba SPECS/wireshark.spec && \
+ echo "Package successfully built in `pwd`/RPMS." && \
+ rm -f SOURCES/$(distdir).tar.bz2 $(distdir).tar.bz2 ; \
else \
echo "Error: RPM executable and/or source directory not found." ; \
false; \