aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames-ws@darkjames.pl>2017-12-06 21:10:29 +0100
committerGerald Combs <gerald@wireshark.org>2017-12-07 23:26:52 +0000
commit038aa2a616db5ba658bee25dee5e55a716d4984a (patch)
treea32b974aab37a1d9d6548348d68d3f94874269cb /Makefile.am
parent8687fca8a821f95075e8c365c7422f157845787b (diff)
Add fuzzshark to cmake/autotools.
Add fuzzshark target to make sure that oss-fuzzshark always build. Change-Id: I802b679c18023daa1475a54bae722b5e90c72a59 Reviewed-on: https://code.wireshark.org/review/24716 Petri-Dish: Jakub Zawadzki <darkjames-ws@darkjames.pl> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 63968c3e0e..af05c5ddb2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,11 +45,12 @@ bin_PROGRAMS = \
@dumpcap_bin@ \
@reordercap_bin@ \
@rawshark_bin@ \
- @sharkd_bin@
+ @sharkd_bin@ \
+ @fuzzshark_bin@
EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype \
editcap mergecap dftest randpkt text2pcap dumpcap reordercap \
- rawshark sharkd
+ rawshark sharkd fuzzshark
#
# Wireshark configuration files are put in $(pkgdatadir).
@@ -453,6 +454,22 @@ wireshark_gtk_LDADD = \
@PORTAUDIO_LIBS@
endif
+fuzzshark_SOURCES = \
+ tools/oss-fuzzshark/fuzzshark.c \
+ tools/oss-fuzzshark/StandaloneFuzzTargetMain.c \
+ version_info.c
+
+fuzzshark_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
+
+fuzzshark_LDFLAGS = $(AM_LDFLAGS)
+
+fuzzshark_LDADD = \
+ wiretap/libwiretap.la \
+ epan/libwireshark.la \
+ wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ ${EPAN_EXTRA_LIBS}
+
tshark_SOURCES = \
$(SHARK_COMMON_SRC) \
capture_opts.c \