aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2008-07-02 01:44:30 +0000
committerGuy Harris <guy@alum.mit.edu>2008-07-02 01:44:30 +0000
commita04774395fbfa44a90f0c217cf2ab85625b1ea9d (patch)
tree8ea9e8c8e701741d179fd1a61f2927dfb49af0d5 /Makefile.am
parent40773753adb08df3eebefabfae29a28783fe5b48 (diff)
Add Makefile.common files for epan/dfilter and epan/ftypes.
Add checkapi rules to Makefile.am files. svn path=/trunk/; revision=25656
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 45bc71d9b8..be4acf4b04 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -986,3 +986,33 @@ osx-package: osx-app
clean-local:
rm -rf $(top_stagedir)
+checkapi_local:
+ $(PERL) tools/checkAPIs.pl \
+ $(TSHARK_TAP_SRC)
+# $(wireshark_SOURCES)
+# $(EXTRA_wireshark_SOURCES)
+
+checkapi: checkapi_local
+ cd wiretap
+ $(MAKE) checkapi
+ cd ../codecs
+ $(MAKE) checkapi
+ cd ../gtk
+## $(MAKE) checkapi
+ cd ../epan
+## $(MAKE) checkapi
+ cd ../epan/crypt
+## $(MAKE) checkapi
+ cd ../dfilter
+ $(MAKE) checkapi
+ cd ../ftypes
+## $(MAKE) checkapi
+ cd ../wslua
+## $(MAKE) checkapi
+ cd ../dissectors
+ $(MAKE) checkapi
+ cd ..
+ cd ../plugins
+ $(MAKE) checkapi
+ cd ../wsutil
+ $(MAKE) checkapi