aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2000-07-22 04:10:23 +0000
committerGerald Combs <gerald@wireshark.org>2000-07-22 04:10:23 +0000
commit354dcbfbf58b89f5577b2046499d133a939031b2 (patch)
tree727493606f637b9677afefe0bfb0cdc8ff739621 /Makefile.am
parente88d4d3a3029f5c8f8bae73b317d225d3c85845a (diff)
Add support for bulding Solaris binary packages. The distribution
is installed in packaging/solaris.stage, and from there the package is created. The checkinstall script depends on GTK+/Glib residing in /usr/local. svn path=/trunk/; revision=2151
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1dd2e69c2b..ef058fc2b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.210 2000/07/21 12:56:57 gram Exp $
+# $Id: Makefile.am,v 1.211 2000/07/22 04:09:53 gerald Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -563,3 +563,28 @@ dfilter-scanner.c : dfilter-scanner.l
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status --recheck
+
+# We load top_stagedir with an explicit path so that libtool doesn't freak.
+top_stagedir=`cd $(top_srcdir) && pwd`/packaging/solaris.stage
+stagedir=$(top_stagedir)/$(PACKAGE).stage
+host_cpu=@host_cpu@
+host_os=@host_os@
+
+solaris-package: $(bin_SCRIPTS) $(lib_LTLIBRARIES)
+ case x$(host_os) in \
+ xsolaris*) \
+ rm -rf $(stagedir) ; \
+ $(MAKE) DESTDIR=$(stagedir) install-strip; \
+ $(srcdir)/packaging/solaris/mkpkg \
+ $(PACKAGE) \
+ $(PACKAGE)-$(VERSION)-$(host_os)-$(host_cpu)-local \
+ $(prefix) \
+ $(top_stagedir) \
+ ;; \
+ *) \
+ echo "Solaris packages can only be built on machines running Solaris." ; \
+ ;; \
+ esac
+
+clean-local:
+ rm -rf $(top_stagedir)