aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2000-05-11 08:18:09 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2000-05-11 08:18:09 +0000
commit292e38e2c61edcd14bfa30ca3c72bacda1bcbe32 (patch)
treedb4edef02456a48d0f6d505166ac7d70f6c0f644 /Makefile.am
parent162800efb308901e0c302517be01226130e39b19 (diff)
Add tvbuff class.
Add exceptions routines. Convert proto_tree_add_*() routines to require tvbuff_t* argument. Convert all dissectors to pass NULL argument ("NullTVB" macro == NULL) as the tvbuff_t* argument to proto_tree_add_*() routines. dissect_packet() creates a tvbuff_t, wraps the next dissect call in a TRY block, will print "Short Frame" on the proto_tree if a BoundsError exception is caught. The FDDI dissector is converted to use tvbuff's. svn path=/trunk/; revision=1939
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3783bdae6f..e8006b2522 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.194 2000/05/11 07:34:31 guy Exp $
+# $Id: Makefile.am,v 1.195 2000/05/11 08:14:47 gram Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -248,6 +248,9 @@ ETHEREAL_COMMON_SOURCES = \
dfilter.c \
dfilter.h \
etypes.h \
+ except.c \
+ except.h \
+ exceptions.h \
follow.c \
follow.h \
inet_v6defs.h \
@@ -276,6 +279,8 @@ ETHEREAL_COMMON_SOURCES = \
resolv.h \
smb.h \
timestamp.h \
+ tvbuff.c \
+ tvbuff.h \
util.c \
util.h \
xdlc.c \
@@ -438,6 +443,8 @@ randpkt.o: randpkt.c
randpkt: randpkt.o wiretap/libwiretap.a
$(LINK) -o randpkt randpkt.o wiretap/libwiretap.a `glib-config --libs` -lz
+tvbtest: tvbtest.o tvbuff.o except.o
+
DISTCLEANFILES = \
register.c \
rdps \