aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-07-13 11:02:52 -0700
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-07-14 03:56:05 +0000
commitff60fcf92dfc33f001e990268d060af4e97bfb7a (patch)
treef7ddf489056f771d9df862b7e63e179ea7707b34 /CMakeLists.txt
parent9ae60d84839bd4d3d8d1051b63ad7bc600e68302 (diff)
CMake: Adjust wsutil includes and linking.
Mark wsutil's includes SYSTEM PRIVATE. This exposed a lot of targets that were indirectly picking up include paths via the wsutil target, so add direct includes where needed. The G.722 and G.726 codecs were implicilty including tiffio.h; find it explicitly instead. Mark some of wsutil's libraries PRIVATE, but leave commonly-used ones PUBLIC. Ping #17477.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 861087d044..2d891e75ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,7 +78,7 @@ if (ENABLE_LTO)
set(CMAKE_INTERPROCEDURAL_OPTIMIZATION TRUE)
message(STATUS "LTO/IPO is enabled")
else()
- message(STATUS "LTO/IPO requested but it is not supported by the compiler: ${lto_output}")
+ message(STATUS "LTO/IPO requested but it is not supported by the compiler: ${lto_output}")
endif()
else()
message(STATUS "LTO/IPO is not enabled")
@@ -1248,6 +1248,8 @@ ws_find_package(NL ENABLE_NETLINK HAVE_LIBNL)
ws_find_package(SBC ENABLE_SBC HAVE_SBC)
+# SpanDSP codec
+find_package(TIFF QUIET)
ws_find_package(SPANDSP ENABLE_SPANDSP HAVE_SPANDSP)
ws_find_package(BCG729 ENABLE_BCG729 HAVE_BCG729)
@@ -1402,10 +1404,11 @@ endif()
# Platform-specific additional libraries.
#
if(WIN32)
+ set(WIN_COMCTL32_LIBRARY comctl32.lib)
+ set(WIN_IPHLPAPI_LIBRARY iphlpapi.lib)
set(WIN_PSAPI_LIBRARY psapi.lib)
- set(WIN_WS2_32_LIBRARY ws2_32.lib)
- set(WIN_COMCTL32_LIBRARY comctl32.lib )
set(WIN_VERSION_LIBRARY version.lib)
+ set(WIN_WS2_32_LIBRARY ws2_32.lib)
endif()
if(APPLE)
@@ -2780,6 +2783,7 @@ if(BUILD_capinfos)
add_executable(capinfos ${capinfos_FILES})
set_extra_executable_properties(capinfos "Executables")
target_link_libraries(capinfos ${capinfos_LIBS})
+ target_include_directories(capinfos SYSTEM PRIVATE ${GCRYPT_INCLUDE_DIRS})
install(TARGETS capinfos RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -2820,6 +2824,7 @@ if(BUILD_editcap)
add_executable(editcap ${editcap_FILES})
set_extra_executable_properties(editcap "Executables")
target_link_libraries(editcap ${editcap_LIBS})
+ target_include_directories(editcap SYSTEM PRIVATE ${GCRYPT_INCLUDE_DIRS})
install(TARGETS editcap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()