aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-04-09 14:14:04 -0700
committerGerald Combs <gerald@wireshark.org>2022-04-18 18:57:43 +0000
commitfea6591b0c84660f46c06029e664e2a9af18fe87 (patch)
treef4192581b2ebb181e668dc52781f9ae39c362ce7 /CMakeLists.txt
parentc8d9c6fc6a92d83c34160b8c4490f6495d57f605 (diff)
macOS: Add support for Sparkle 2.
Sparkle 2 deprecated the sharedUpdater singleton, so create our own which uses Sparkle 2's updated API. Ping #18035. Update our CMake version check.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd263777ed..38dab95e5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1245,7 +1245,7 @@ if(BUILD_wireshark OR BUILD_logwolf)
endif()
set(QT_FOUND ON)
if(APPLE)
- ws_find_package(Sparkle ENABLE_SPARKLE HAVE_SOFTWARE_UPDATE 1 EXACT)
+ ws_find_package(Sparkle ENABLE_SPARKLE HAVE_SOFTWARE_UPDATE 1)
endif()
if(Qt${qtver}Multimedia_FOUND)
set(QT_MULTIMEDIA_LIB 1)