aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-04-25 09:04:55 -0700
committerGerald Combs <gerald@wireshark.org>2022-04-25 09:18:57 -0700
commitfc2cc05dde517957799f912331d5c2ac31867444 (patch)
tree37a10f61facfc955529d3a62de03d8eca8f9c7f1 /CMakeLists.txt
parent2b24b512cad1409fe78303502f1f876df84cf6f8 (diff)
Move some configuration and data files to resources/share.
Create resources/share/wireshark and resources/share/logwolf. Move various data and configuration files to resources/share/wireshark and add resources/share/logwolf/colorfilters.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 13 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6cfed13254..1182d47042 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1901,28 +1901,30 @@ set(TSHARK_TAP_SRC
)
+# Installed into ${DATAFILE_DIR}
set(INSTALL_DIRS
+ resources/share/wireshark/profiles
resources/protocols/diameter
resources/protocols/dtds
- profiles
resources/protocols/radius
resources/protocols/tpncp
resources/protocols/wimaxasncp
)
+# Installed into ${DATAFILE_DIR}
set(INSTALL_FILES
- cfilters
- colorfilters
- dfilters
- dfilter_macros
+ docbook/ws.css
enterprises.tsv
- ipmap.html
manuf
- pdml2html.xsl
+ resources/share/wireshark/cfilters
+ resources/share/wireshark/colorfilters
+ resources/share/wireshark/dfilter_macros
+ resources/share/wireshark/dfilters
+ resources/share/wireshark/ipmap.html
+ resources/share/wireshark/pdml2html.xsl
+ resources/share/wireshark/smi_modules
services
- smi_modules
wka
- docbook/ws.css
)
if (ASCIIDOCTOR_FOUND)
@@ -2349,7 +2351,7 @@ add_custom_command(
WORKING_DIRECTORY ${_protocol_data_dir}
)
-file(GLOB _profiles_src_files RELATIVE "${CMAKE_SOURCE_DIR}" profiles/*/*)
+file(GLOB _profiles_src_files RELATIVE "${CMAKE_SOURCE_DIR}" resources/share/wireshark/profiles/*/*)
set (_profiles_data_files)
foreach(_data_file ${_profiles_src_files})
list(APPEND _profiles_data_files "${DATAFILE_DIR}/${_data_file}")
@@ -2358,7 +2360,7 @@ endforeach()
add_custom_command(
OUTPUT ${_profiles_data_files}
COMMAND ${CMAKE_COMMAND} -E copy_directory
- "${CMAKE_SOURCE_DIR}/profiles" "${DATAFILE_DIR}/profiles"
+ "${CMAKE_SOURCE_DIR}/resources/share/wireshark/profiles" "${DATAFILE_DIR}/profiles"
)
list(APPEND copy_data_files_depends