aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-03 01:45:32 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-03 08:46:01 +0000
commitb4ce352539ec1e88a8002c65a38cc3029860c0e0 (patch)
treef2c702b2722c20464477e5f85cb5c80abab31915 /CMakeLists.txt
parentd70e56a733a1d432dedc0dce7fbd992ef225d0c5 (diff)
Make --help and --version information a bit more uniform.
Have --version print the version number, the copyright information, the "compiled with" information, the "running on/with" information, and the compiler information. Have --help print the version number, a one-line summary of what the program does, a reference to http://www.wireshark.org for more information, a Usage: line, and a list of command-line options. This means programs doing that don't need to include version.h; that's left up to get_ws_vcs_version_info() to do. Change-Id: Idac641bc10e4dfd04c9914d379b3a3e0cc5ca8cb Reviewed-on: https://code.wireshark.org/review/2794 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b25965ad11..7f4a36663c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -921,7 +921,6 @@ set(SHARK_COMMON_SRC
capture-pcap-util.c
cfile.c
frame_tvbuff.c
- ${CMAKE_BINARY_DIR}/version.h
sync_pipe_write.c
version_info.c
)
@@ -1221,6 +1220,7 @@ if(BUILD_text2pcap)
set(text2pcap_CLEAN_FILES
text2pcap.c
pcapio.c
+ version_info.c
)
set(text2pcap_FILES
${text2pcap_CLEAN_FILES}
@@ -1245,7 +1245,7 @@ if(BUILD_mergecap)
)
set(mergecap_FILES
mergecap.c
- ${CMAKE_BINARY_DIR}/version.h
+ version_info.c
image/mergecap.rc
)
add_executable(mergecap ${mergecap_FILES})
@@ -1264,7 +1264,7 @@ if(BUILD_reordercap)
)
set(reordercap_FILES
reordercap.c
- ${CMAKE_BINARY_DIR}/version.h
+ version_info.c
image/reordercap.rc
)
add_executable(reordercap ${reordercap_FILES})
@@ -1285,6 +1285,7 @@ if(BUILD_capinfos)
)
set(capinfos_FILES
capinfos.c
+ version_info.c
image/capinfos.rc
)
add_executable(capinfos ${capinfos_FILES})
@@ -1322,6 +1323,7 @@ if(BUILD_editcap)
)
set(editcap_FILES
editcap.c
+ version_info.c
image/editcap.rc
)
add_executable(editcap ${editcap_FILES})
@@ -1347,7 +1349,6 @@ if(BUILD_dumpcap AND PCAP_FOUND)
${NL_LIBRARIES}
)
set(dumpcap_FILES
- ${CMAKE_BINARY_DIR}/version.h
capture_opts.c
capture-pcap-util.c
capture_stop_conditions.c