aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Weiß <paulniklasweiss@gmail.com>2021-02-15 19:38:23 +0100
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-03-26 06:44:25 +0000
commit8c1b29a597764cd3e43151b4765f40884f984db0 (patch)
treefbfe288263effbc58e452eb35c5dcc99704fca74 /CMakeLists.txt
parent880edd9009acf7758c77791b786673870c17f58e (diff)
Regex based textfile import
Modularized the parser backend slightly to have the needed hooks Modified the timestamp format slightly to enable arbitrary postion for second fractions Added a regex based seeking parser for textfiles as frontend alternative to text_import_scanner.l Regex is using the GLib implementation Supported frame-data formats are bin, hex, oct and base64 Regex based importing UI Fixed Meory-leak in ImportTextDialog::exec() A new tab was added to the text_import ui to accomodate the new fields Hints are available and styled accordingly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90d4bc1bcf..23a8bd42f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -674,6 +674,15 @@ else() # ! MSVC
# -Wimplicit-function-declaration into an error by default.
#
-Werror=implicit
+ #
+ # the value used for uninitialized fields is 0 and cannot be changed
+ # the workaround is to initialize everything to the wanted default
+ # any subsequent initializers then cause this warning
+ #
+ # XXX: in theory c++20+ could have this issue aswell, but we don't
+ # use designated initializers in c++ code anyway.
+ #
+ -Wno-override-init
)
#