aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-03 03:40:11 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-03 10:41:19 +0000
commit7df03a7c3ec4c89a3f623d00f828bc66ce120ddc (patch)
tree244d52cd9b9ae73f4e927f3f85574973b97fb09d /CMakeLists.txt
parent8d51a50a819b293d5bfb95238b9fb11d8789b988 (diff)
Get rid of debugging output, and get CMake to produce verbose makefiles.
On the 32-bit OS X buildbot, automake is old enough that autotools builds are verbose, printing the command line for each compile step; if we cause CMake to produce verbose makefiles, they will also print the command line, so we can see what differences there are. This means the other debugging output we added isn't necessary; remove it. Sort the extra warning options in configure.ac based on whether they're for C and C++ or just C, just as is the case in CMake, to make it easier to keep the lists in sync; add comments to configure.ac to mirror the ones in CMakeLists.txt. Get rid of -Wno-deprecated-declarations; the CMake build doesn't use it, and it doesn't appear to be necessary - if we ever have problems with OS X complaining about using OpenSSL, for example, we should do as tcpdump does and wrap uses of the "deprecated"-but-cross-platform APIs in the appropriate pragmas. Change-Id: I0b8b45f00481ac2b67da5c7dd028a029b130dcc4 Reviewed-on: https://code.wireshark.org/review/3377 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 10 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea6668a435..9a9b8e2628 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,13 @@ project(Wireshark C CXX)
cmake_minimum_required(VERSION 2.8.3)
+#
+# XXX - force verbose Makefiles, to try to debug some differences
+# in warnings generated on the 32-bit OS X buildbot for autotools
+# builds and CMake builds.
+#
+set(CMAKE_VERBOSE_MAKEFILE ON)
+
# Needs to be set after cmake_minimum_required or cmake_policy(VERSION)
# Policy since 2.6.1
cmake_policy(SET CMP0008 NEW)
@@ -242,10 +249,10 @@ else()
set(WIRESHARK_EXTRA_COMPILER_COMMON_FLAGS
# The following are for C and C++
-pedantic
- -Woverflow
#
# Various code blocks this one.
#
+ -Woverflow
-fstrict-overflow -Wstrict-overflow=4
#
# Due to various places where APIs we don't control
@@ -265,8 +272,9 @@ else()
#
-Wunsafe-loop-optimizations
#
- # All the registration functions block this for now.
+ # All the registration functions block these for now.
#
+ -Wmissing-prototypes
-Wmissing-declarations
#
# A bunch of "that might not work on SPARC" code blocks
@@ -292,10 +300,6 @@ else()
# never enable this one with -Werror.
#
-Wbad-function-cast
- #
- # All the registration functions block this for now.
- #
- -Wmissing-prototypes
)
set(WIRESHARK_EXTRA_COMPILER_CPP_ONLY_FLAGS
@@ -701,9 +705,7 @@ elseif(QT_FOUND)
message(STATUS "QT libs: ${QT_LIBRARIES}")
endif()
-message(STATUS "C compiler: ${CMAKE_C_COMPILER}")
message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
-message(STATUS "C++ compiler: ${CMAKE_CXX_COMPILER}")
message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
include(ConfigureChecks.cmake)