aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-06-15 20:33:46 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-06-15 20:30:31 +0000
commit678c5d5da6eac9c6de6d1b05cbcc03600b529f7e (patch)
tree437cb0f11ed1da68df0df4bce61f4832ec94423e /CMakeLists.txt
parent86285d552e9b8a892687741a08cecb1404338dd5 (diff)
Fix the CMake windows installer to pickup the locally built zlib1.dll
Change-Id: I8880a760d9817dd038694e96b4a3d9b8d2db3c2c Reviewed-on: https://code.wireshark.org/review/8931 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f724919a34..728b92f1c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -711,6 +711,7 @@ if(ENABLE_ZLIB)
add_subdirectory("${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_INCLUDE_DIR "${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_LIBRARY zlib)
+ set(ZLIB_DLL "zlib1.dll")
set_target_properties(zlib PROPERTIES FOLDER "Libs/zlib")
# Annoyingly zlib also builds some other stuff we aren't interested in
set_target_properties(zlibstatic PROPERTIES FOLDER "Libs/zlib")