aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2015-09-09 16:46:34 -0400
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-09-10 11:59:56 +0000
commit5eee0b9e4459ab95083524bc1d430524e63f44d2 (patch)
tree6f20b317eec9838fa43710a0c546ebbf515688ee /CMakeLists.txt
parent37bee87a5205c87798e8d1de65c0dcbdbf3b92f6 (diff)
Don't use any -fsanitize options unless we're using ASAN.
This lets cmake users configure without installing libusan. A better or more final fix awaits a decision in bug 11009. Change-Id: Iea6c4e2ce31817c17931a448f0c72da2a31a2e6d Ping-Bug: 11009 Reviewed-on: https://code.wireshark.org/review/10454 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47c55da954..9c16b3b1f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -346,11 +346,6 @@ else()
-fwrapv
-fno-strict-overflow
-fno-delete-null-pointer-checks
- -fsanitize=undefined # compile and runtime checks
- # -fsanitize=float-divide-by-zero
- # -fsanitize=float-cast-overflow
- # -fsanitize=address
- # -fno-sanitize-recover # Abort during runtime
-Wvla
-Waddress
-Wattributes
@@ -465,6 +460,10 @@ else()
# and no yet all leak is fixed...
# use ASAN_OPTIONS=detect_leaks=0 to disable detect_leaks
-fsanitize=address
+ -fsanitize=undefined # compile and runtime checks
+ # -fsanitize=float-divide-by-zero
+ # -fsanitize=float-cast-overflow
+ # -fno-sanitize-recover # Abort during runtime
)
if(ENABLE_ASAN)