aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 15:45:44 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-02 22:46:39 +0000
commit55646c8427bbb2bef7903a181c6272da642eb2c4 (patch)
tree694f9e22afd0976c08658105fe7d045f4c69f999 /CMakeLists.txt
parente2969cbb3cc533ad0214e3d2d86d9543930c1528 (diff)
Always check some -f flags.
Now that we check each flag with all previously-accepted flags, this catches the case where -fwrapv causes -fno-strict-overflow to produce a warning when tested. This way, what we do matches what the autotools do. Change-Id: I68ce281dc33a32b591e3137db626f2749c4a0708 Reviewed-on: https://code.wireshark.org/review/3370 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b603c3a56f..b0373e37b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,6 +215,9 @@ else()
-Wwrite-strings
-Wno-long-long
-Wheader-guard
+ -fwrapv
+ -fno-strict-overflow
+ -fno-delete-null-pointer-checks
)
set(WIRESHARK_C_ONLY_FLAGS
@@ -277,9 +280,6 @@ else()
# (about glib library not using Doxygen)
#
-Wdocumentation
- -fwrapv
- -fno-strict-overflow
- -fno-delete-null-pointer-checks
)
set(WIRESHARK_EXTRA_COMPILER_C_ONLY_FLAGS