aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 17:46:32 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-03 00:47:00 +0000
commit5234d4c2d09bd60831b51761faab7fb2f6821b65 (patch)
tree1ed5a7daa6584d136db0942fb55683633a6a08c6 /CMakeLists.txt
parent2dd269091e52fa93485667dc69ddb401ec71297f (diff)
OK, try sorting the compiler options.
Also, comment out the addition of -Wno-deprecated-declarations, as the CMake build doesn't use it. If this succeeds in making the autotools and CMake builds compile C code with the same -W and -f flags in the same order, that should eliminate at least one reason why the CMake build produces compiler warnings that the autotools build doesn't. Change-Id: I0eaeae91b8e3c39c53f502daef86c2d103c8bdab Reviewed-on: https://code.wireshark.org/review/3374 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6fd590b61..eed1b2bea9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -206,6 +206,9 @@ else()
-Wpointer-arith
-Warray-bounds
-Wformat-security
+ -fwrapv
+ -fno-strict-overflow
+ -fno-delete-null-pointer-checks
-Wvla
-Waddress
-Wattributes
@@ -216,9 +219,6 @@ else()
-Wwrite-strings
-Wno-long-long
-Wheader-guard
- -fwrapv
- -fno-strict-overflow
- -fno-delete-null-pointer-checks
)
set(WIRESHARK_C_ONLY_FLAGS