aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 14:01:07 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-02 21:01:49 +0000
commit50b67345b7eb35ae271b393b1e416f487338a1de (patch)
tree376d23828f0c6479d393277ee66131f35b1784d4 /CMakeLists.txt
parent493c4c20bd795fa5baafea8313eb956a9248202d (diff)
Dump additional debugging information.
For autotools, dump CC, CFLAGS, CXX, and CXXFLAGS. For CMake, dump CMAKE_C_COMPILER_ID and CMAKE_CXX_COMPILER_ID. Hopefully this will help figure out why CMake builds catch different warnings from autotools builds. Change-Id: I26955ad955f60e8bad248562fa87963a3a1bb42f Reviewed-on: https://code.wireshark.org/review/3365 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9dd8361f86..f962454c7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -699,7 +699,9 @@ elseif(QT_FOUND)
message(STATUS "QT libs: ${QT_LIBRARIES}")
endif()
+message(STATUS "C compiler: ${CMAKE_C_COMPILER_ID}")
message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
+message(STATUS "C++ compiler: ${CMAKE_CXX_COMPILER_ID}")
message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
include(ConfigureChecks.cmake)