aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 13:53:44 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-02 20:54:16 +0000
commit493c4c20bd795fa5baafea8313eb956a9248202d (patch)
treeb9de781e6fef55f4711d9206ed0184793726469c /CMakeLists.txt
parent7f937c9bf72ffe1ca0e54ac87ff635cd1a873694 (diff)
Wait until the C and C++ compiler flags are fully set before showing them.
That way, we report the *full* contents of those flags. Change-Id: Idab78049247c04b7d35a3ce804c8ea9daaf84312 Reviewed-on: https://code.wireshark.org/review/3364 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7618e5125a..9dd8361f86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,9 +368,6 @@ foreach(THIS_FLAG ${CPP_FLAG_TESTS})
endforeach()
set(CMAKE_CXX_FLAGS "${ADDED_CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS}")
-message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
-message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
-
#
# XXX - we're assuming MSVC supports the SSE 4.2 intrinsics and
# that other C compilers support them iff they support the
@@ -701,6 +698,10 @@ elseif(QT_FOUND)
message(STATUS "QT includes: ${QT_INCLUDE_DIR}")
message(STATUS "QT libs: ${QT_LIBRARIES}")
endif()
+
+message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
+message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
+
include(ConfigureChecks.cmake)
#Big or little endian ?