aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 18:34:11 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-03 01:34:41 +0000
commit363f1e567cf3a43426f00e35c8eaf06c0a1f5b81 (patch)
treefc31784d1679055580f89878f5cde16c930a19ab /CMakeLists.txt
parent5234d4c2d09bd60831b51761faab7fb2f6821b65 (diff)
Print the actual compiler, not its "CMake-id".
Hopefully this will help figure out whether we're using different compilers for the autotools and CMake builds. Change-Id: If6d2ee93cd14570c53723140dcedf347600cbe34 Reviewed-on: https://code.wireshark.org/review/3375 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eed1b2bea9..ea6668a435 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -701,9 +701,9 @@ elseif(QT_FOUND)
message(STATUS "QT libs: ${QT_LIBRARIES}")
endif()
-message(STATUS "C compiler: ${CMAKE_C_COMPILER_ID}")
+message(STATUS "C compiler: ${CMAKE_C_COMPILER}")
message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
-message(STATUS "C++ compiler: ${CMAKE_CXX_COMPILER_ID}")
+message(STATUS "C++ compiler: ${CMAKE_CXX_COMPILER}")
message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
include(ConfigureChecks.cmake)